Back to overview
Degraded
Degraded Connectivity to the Washington Cloud Edge Region
Mar 21 at 11:50am CET
Affected services
Persistent Nodes
Resolved
Mar 21 at 12:06pm CET
The issue has been resolved, and the network has remained stable for the past 15 minutes. We will continue to monitor the situation closely.
Affected services
Created
Mar 21 at 11:50am CET
We are currently experiencing degraded performance in the Washington Cloud Edge Region, including intermittent packet loss that may reach up to 100%.
The issue began on 2025-03-21 at 10:42:15 UTC.
Our engineering team is actively investigating the issue and working to restore full service as quickly as possible. We will continue to provide updates as more information becomes available.
Affected services